A new V2 version of AstraClipboard will be developed, with major security, design and stability improvements. The new version will be live soon. Thank you for your patience!
Posted Dec 26, 2025 - 22:05 CET
Investigating
A severe problem with the backend was discovered, which has made the whole website unusable. We are working hard to find and resolve the problem.
Posted Dec 26, 2025 - 16:49 CET
This incident affects: Homepage, Paste Management, Blog, and AstraLabs.